Apple Subscription not recognised
We are aware of an issue that you may experience on / or after your iTunes billing renewal period has just passed. Please see below.
Customers affected
Customers who have subscribed to TVPlayer via Apple/Itunes store in-app purchase.
Impact
Upon or shortly after your billing renewal, your subscription may not be recognised.
Upon trying to access a Premium channel, you may see a message asking you upgrade or subscribe.
Cause
Users who have not restarted their app recently may experience a synchronisation error. Essentially our systems have not received an update confirming your current subscription status.
Workaround
The fix to this, please:
Go to the Account section of the TVPlayer app and press Try Premium and then Continue followed by Restore Purchase.
Alternatively, force stop the app on the Apple device that is linked to the original Apple in-app subscription. Learn how to force top an app
- then log out and log in again
Fix
We are actively working to release a fix for this shortly.